AccueilRechercherMembresGroupesS'enregistrerFAQConnexion

Partagez| .

[Question technique] Décalage son-image

Voir le sujet précédent Voir le sujet suivant Aller en bas
AuteurMessage
NeZiaK
Subber Actif
Subber Actif
Age : 31
Date d'inscription : 06/07/2016
Messages : 147
Etat : Carrément !

MessageSujet: [Question technique] Décalage son-image Sam 9 Juil - 17:05

Bonjour  :)

Je me sens un peu gêné de poser une question sans avoir encore réussis à uploader ma première traduction, mais j'ai passé la journée à bidouiller et je m'arrache les poils.
En plus, je pense que le sujet pourrait en intéresser plus d'un...

Donc, le problème : Ma vidéo est traduite, j'ai fait une conversion en AVI, puis un encodage avec Virtualdub pour incorporer les sous titres.
C'est joli, mais le son et l'image ne sont pas synchro.
La désynchro est constante, donc je règle le problème en décalant le son de 200-300ms.
(merci à aldo006 dont les tutos m'ont beaucoup aidés)

C'est magnifique, ça fonctionne, je l'upload sur youtube, je la mate, et les son et l'image sont à nouveau désynchronisés. J'ai tenté de décaler le son au hasard sur virtualdub, réuploader, en vain.
Je me demande si le décalage à l'upload sur youtube ne change pas à reupload de la vidéo. sinon est-ce que quelqu'un connais la valeur de décalage ? Je vais continuer de chercher...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur https://www.youtube.com/channel/UCDSB7IaE0ULyomiWGATDEpw
Aldo006
Admin
Admin
Age : 34
Date d'inscription : 19/09/2012
Messages : 2698

MessageSujet: Re: [Question technique] Décalage son-image Sam 9 Juil - 17:12

La vidéo que tu as téléchargée au tout départ, sans encodage ni rien, elle a un décalage ou pas?

la boulette!

Si la vidéo de base est parfaite, c'est que le problème vient de ton encodage, donc peut-être un souci de codecs.

Tu as le K-lite codec pack d'installé sur ton PC?
http://www.clubic.com/telecharger-fiche35534-k-lite-codec-pack.html

Et le Xvid HD que j'ai conseillé dans les outils indispensables (dans le 5/)?
http://www.ncvostfr.com/t2025-outils-les-outils-indispensables-pour-devenir-sous-titreur

http://www.ncvostfr.com/t2581-encodage-qualite-de-video-encoder-en-hd-avec-xvid

____________________________________________________________________________________________________________________________________________
 
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.ncvostfr.com http://www.dailymotion.com/aldo006 http://www.youtube.com/user/aldo006
NeZiaK
Subber Actif
Subber Actif
Age : 31
Date d'inscription : 06/07/2016
Messages : 147
Etat : Carrément !

MessageSujet: [question technique] Décalage son-image Sam 9 Juil - 17:30

au départ c'est un mp4 changé en AVI, sinon virtualdub ne l'accepte pas.
L'AVI est synchro comme il faut, mais une fois que je rajoute les sous titres dans virtual dub et que j'encode, le résultat est out of sync, sauf si je met une correction de 200ms.
une fois encodée (donc AVI sous titrée) elle est bien synchro mais se désynchronise une fois uploadée sur youtube.

sinon pas sur que j'avais K-lite, je vais réessayer.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur https://www.youtube.com/channel/UCDSB7IaE0ULyomiWGATDEpw
Aldo006
Admin
Admin
Age : 34
Date d'inscription : 19/09/2012
Messages : 2698

MessageSujet: Re: [Question technique] Décalage son-image Sam 9 Juil - 17:32

Pour la passer de MP4 à avi, tu te sers du logiciel conseillé ici (en 6/)?
http://www.ncvostfr.com/t2025-outils-les-outils-indispensables-pour-devenir-sous-titreur

____________________________________________________________________________________________________________________________________________
 
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.ncvostfr.com http://www.dailymotion.com/aldo006 http://www.youtube.com/user/aldo006
NeZiaK
Subber Actif
Subber Actif
Age : 31
Date d'inscription : 06/07/2016
Messages : 147
Etat : Carrément !

MessageSujet: [question technique] Décalage son-image Sam 9 Juil - 17:34

yep, pazera oui
Revenir en haut Aller en bas
Voir le profil de l'utilisateur https://www.youtube.com/channel/UCDSB7IaE0ULyomiWGATDEpw
Montcuq
Modérateur-Subber
Modérateur-Subber
Age : 19
Date d'inscription : 02/11/2012
Messages : 449
Etat : "Most of the US voters are so stupid!" _Wabuu

MessageSujet: Re: [Question technique] Décalage son-image Sam 9 Juil - 17:52

Peut-être que si tu n'appliques pas de correction à la vidéo sous-titrée, elle ne sera pas désynchro sur YouTube ? aucune idée...

Sinon, essaye peut-être d'utiliser AVI Recomp pour incruster les sous-titres : http://www.ncvostfr.com/t2636-incrustations-incruster-des-sous-titres-avec-format-factory-ou-avi-recomp-quand-virtual-dub-ne-marche-pas

____________________________________________________________________________________________________________________________________________
Modérateur à l'humour douteux et à l'art déviant.
Gérant principal des comptes Twitter et YouTube officiels des Fans de NC.
Sur d'autres sites, mon pseudo est Jdtendo, mais c'est clairement moins marrant que "Montcuq", qu'on se le dise !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://montcuq-prod.over-blog.com/ http://www.dailymotion.com/Jdtendo http://www.youtube.com/Jdtendo
NeZiaK
Subber Actif
Subber Actif
Age : 31
Date d'inscription : 06/07/2016
Messages : 147
Etat : Carrément !

MessageSujet: [question technique] Décalage son-image Sam 9 Juil - 18:07

eheh j'ai essayé... en fait j'ai uploadé des échantillons sur youtube avec différents décalages du son. Un d'eux à fonctionné, j'ai donc encodé la totalité de la vidéo avec le même décalage, uploadé sur youtube, et... c'est pas synchro. Donc ça dépend peut -être de la taille du fichier.
je continue mes expériences, si ça ne va pas je m'interesserai à AVIrecomp. à moins que...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur https://www.youtube.com/channel/UCDSB7IaE0ULyomiWGATDEpw
NeZiaK
Subber Actif
Subber Actif
Age : 31
Date d'inscription : 06/07/2016
Messages : 147
Etat : Carrément !

MessageSujet: [question technique] Décalage son-image Dim 10 Juil - 15:55

Bon, le problème est résolu... je ne sais pas comment par contre et la synchro n'est pas parfaite (vous pouvez voir le résultat dans la catégorie AVGN), mais bon ça fera l'affaire. merci à tous pour votre aide ma faute!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur https://www.youtube.com/channel/UCDSB7IaE0ULyomiWGATDEpw
Montcuq
Modérateur-Subber
Modérateur-Subber
Age : 19
Date d'inscription : 02/11/2012
Messages : 449
Etat : "Most of the US voters are so stupid!" _Wabuu

MessageSujet: Re: [Question technique] Décalage son-image Dim 10 Juil - 16:47

À noter que si tu utilises Aegisub, tu peux décaler les sous-titres dans le temps :


Ça peut être utile pour mieux synchroniser les sous-titres avec la vidéo !

____________________________________________________________________________________________________________________________________________
Modérateur à l'humour douteux et à l'art déviant.
Gérant principal des comptes Twitter et YouTube officiels des Fans de NC.
Sur d'autres sites, mon pseudo est Jdtendo, mais c'est clairement moins marrant que "Montcuq", qu'on se le dise !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://montcuq-prod.over-blog.com/ http://www.dailymotion.com/Jdtendo http://www.youtube.com/Jdtendo
NeZiaK
Subber Actif
Subber Actif
Age : 31
Date d'inscription : 06/07/2016
Messages : 147
Etat : Carrément !

MessageSujet: [Question technique] Décalage son-image Mar 2 Aoû - 15:29

Je soumet la solution que j'ai trouvé au problème de synchro ici, au cas où quelqu'un aurait le même. Je résume le problème d'abord :

- Je télécharge une vidéo sur youtube, puis la transforme en AVI (souvent elle est en mp4 de base) --> jusque là la synchro ne change pas
- Je fais tout mon bazar avec Aegis, jusque là pas de problème
- Je tente de tout encoder avec Vdub, et MEGA gros décalage son et image une fois que la vidéo est encodée !!!
- Je décale le son de 300ms avec l'interleaving de Vsub et c'est parfais, sync parfaite lors du visionnage
- Je upload sur youtube, tente de la lire, et je me retrouve avec un nouveau décalage
- après une 20aines d'upload, j'ai enfin pu trouver que 315ms d'interleaving lors de l'encodage me permet d'avoir une synchro quasi parfaite sur youtube

Donc voilà, si jamais vous avez ce problème, essayez 315ms d'interleaving sur le son, et ça devrait bien se passer.... je suppose j'vous surveille
Revenir en haut Aller en bas
Voir le profil de l'utilisateur https://www.youtube.com/channel/UCDSB7IaE0ULyomiWGATDEpw
Contenu sponsorisé

MessageSujet: Re: [Question technique] Décalage son-image Aujourd'hui à 21:12

Revenir en haut Aller en bas

[Question technique] Décalage son-image

Voir le sujet précédent Voir le sujet suivant Revenir en haut
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Fans de Nostalgia Critic :: Le Coin des Fans :: (Aide) Tutoriels, Suggestions & Soucis Techniques-